Results 1 to 7 of 7

Thread: Fan/Processer/Mother Board/Help!

  1. Fan/Processer/Mother Board/Help!

    So my parents desktop computer has been making loud noises in the past few weeks, and today they went to restart it and it won't boot up. So I opened the computer up and the inside was covered in dust. Cleaned all of the dust off, mostly concentrated on both fans, and the heat sink area, went to try to boot it up, and it won't boot. The computer sounds like it's starting, but it doesn't boot, and the main thing I noticed is that the fan attached to the power supply isn't spinning. It's trying to spin, but it doesn't actually get started.

    Now my question is, what could be causing this problem? Would a non functioning power supply fan prevent a computer from booting up? And is what would be the best way to figure out exactly what is preventing it from booting it ?

    Any help would be much appreciated. I only know enough about computer hardware to barely scrape by, so troubleshooting any hardware issues isn't something I'm very knowledgeable about.

  2. Well if the fan isn't spinning, it's possible you fried your power supply or it just got old. Those things get damn hot, and if it was running for a little while without the fan running you could have just killed it.

    I would try replacing that first, and if you're still having problems then it could be more than just the power supply. But definitely replace that PSU, if the fan isn't working then it's not going to do you any good.

  3. I can't see a PSU with a non functional fan lasting long, even if the computer started up. Replace that thing and see it helps.... like Trial said.

  4. Looks like I'll try a new PSU then. Thanks for the help guys.

    So I assume your PSU can still "turn on" a computer even if it's no good. But not let it boot up?

  5. The fans in your PSU might not turn on until it gets hot, that's how mine work.

    Are you sure all the cables are plugged in right? You didn't unplug the CPU power cable?


  6. I know the fan isn't working because it's actually trying to spin but isn't able to. I can see it shifting a little bit over and over again like it's trying to spin.

    As for the cables, yeah, all of them are plugged in properly.

  7. Yeah, it's the PSU.

    The good news is they're cheap.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Games.com logo