Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: Do I possibly have disc rot, or a dying CD drive lens?

  1. Quote Originally Posted by NeoZeedeater View Post
    CHILDREN ARE DUMB AND MUST BE DESTROYED BEFORE THEY TAKE OVER

    YOU’LL SEE
    Quote Originally Posted by Fe 26 View Post
    No one uses sigs.

  2. CAPS
    Quote Originally Posted by Fe 26 View Post
    No one uses sigs.

  3. CAN'T GET PAST THE 2ND ROUND

  4. #14
    I'm guessing a laser issue as well. The likelihood of having more than one Saturn disc have rot is get high.

    First, try to clean the laser lens with a qtip and alcohol. If that doesn't work see if there is a pot on the laser you can adjust. On the model 2s there is a pot that adjusts the intensity of the laser, I don't know if that's true with model 1s. If that doesn't work it's time for a new laser or a new Saturn.

  5. Yeah, I've cleaned the lens with a Q-tip. I got Cyberbots to work after I did that and Vampire Savior booted and got lost on a loading screen. I might just crack it open and slightly tweak the pot.

  6. Quote Originally Posted by gamevet View Post
    I've resurrected a dead PS3 that I gave $20 to a friend for, by replacing the dead Blu-Ray drive with one I'd bought off of ebay.

    I'm glad you had good luck with your one purchase. I've purchased dozens of lasers for older systems and I've encountered a high defect rate and half of the lasers that were advertised as "new" were not.
    All I'm saying is don't think it'll be as easy as ordering a replacement laser and popping it in. While it CAN be that easy, my (and others around the net if you want to take a look) experience is that Chinese junk is exactly that. I even had lasers that did work initially but died during a ten hour stress test.

  7. I'll probably just buy a Japanese Saturn instead, because like you said, you never know what you are paying for.

    Adjusting the POT didn't really do much. Vampire Savior locked up at the Capcom Screen. I also had a couple of other titles that wouldn't boot up, but do now. I don't know if having the AR4M+ in there might of had something to do with those newer North American titles not booting.

    Quote Originally Posted by NeoZeedeater View Post
    You could also try running them in an emulator. I have some heavily scratched Sega CD games that work fine through my PC drive but my Sega CD has trouble with them.
    I tried out SSF. The 1st time I put the disk in, the game had an error and jumped out. I went into the performance section, adjusted the settings and the game worked.
    Last edited by gamevet; 15 Oct 2017 at 06:25 PM.

  8. #18
    Quote Originally Posted by NeoZeedeater View Post
    I wouldn't worry too much. Let us all not forget the "wonders" we grew up around.

    I remember kids that couldn't wipe their asses right all the way up to the 3rd grade. This child is a genius in comparison.

  9. How the fuck would you know how clean her ass is?!

  10. #20
    You've got me. The child in the gif may also not know how to wipe.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Games.com logo