Go to Cafe Tropico Cafe Tropico
Go to the Blue Parrot Inn
Search:     Advanced search
10/31/14 at 02:54 PM
Welcome, Guest. Please login or register.

Login with username, password and session length
207942 Posts in 10548 Topics by 2074 Members
Latest Member: cpmoneymakertutorials
   Home   Help Search Calendar Login Register  
Cafe Tropico  |  Tropico  |  Technical Questions / Troubleshooting (Moderator: CafeDave)  |  Topic: Possible Solution to the data3.cab Problem
Pages: [1]   Go Down
  Send this topic  |  Print  
Author Topic: Possible Solution to the data3.cab Problem  (Read 4100 times)
0 Members and 1 Guest are viewing this topic.
Gladiator
Guest
« on: 08/10/02 at 02:49 PM »

Okay:

After going through the Internet and doing some research on the "insert disk 0 with data3.cab" problem, I believe I've found a work around which will make it possible to actually install the game again.

The solution I just tried is to go into the registry, via regedit, and delete any and all previous references to Tropico.  This can be best accomplished by using regedit's "find" feature, searching for all occurences of the word "Tropico", and then deleting the corresponding keys.  As always, be careful when messing with your registry; make sure you don't delete any keys unrelated to the game.

The idea behind this is to essentially trick your computer into believing that it's installing the game again for the first time.  After culling through the Internet on this problem for a few hours, I noticed one consistency:   people would say that the game would install the *first* time, but couldn't be re-installed again.  Why it works only the first time is a mystery, but I tried it and it finally re-installed.

Another thing I found interesting was that apparently this problem with data3.cab is not limited to Tropico.  Searching on Google one can find similar problems with at least several other games:  "The Sims--Hot Date" being the most prevelant.    This suggests that the it may not a bug with Tropico, but with the Installer.  

Hope this helps somebody out there.  Smiley



Report to moderator   Logged
intmd8
Guest
« Reply #1 on: 08/12/02 at 01:13 PM »

i encounter the data3.cab error even in my first install. anyone who has solved this problem???

i already tried...
- turning off my antivirus program
- deleting the contents of c:\windows\temp
- renaming the C:\Program Files\InstallShield Installation Information folder
- copying the contents of the CD to my harddisk then installing from there
- i have a 40x CD-ROM drive, so its not the CD-ROM drives fault.

... but still no luck.
Report to moderator   Logged
Gladiator
Guest
« Reply #2 on: 08/12/02 at 04:50 PM »

Well Jeez, I don't know what to add, then.  

The only thing I can think of is to somehow slow down your CD speed, although I don't know how you'd exactly do this.  People with data3.cab problems related to the other games have reported that this sometimes works.  I've also saw a tech site somewhere that mentioned fiddling with your CD's "sync data" and "DMA" settings, though that didn't work for me.

Like I said, the fact that this problem is occurring with more than just Tropico suggests to me that it's something not to do with Tropico, but maybe InstallShield, or the CD drivers, or something else.  One thing is pretty clear, it's not defective/dirty CD's that are the cause; don't believe it if anyone tells you that's the problem.
Report to moderator   Logged
Gladiator
Guest
« Reply #3 on: 08/16/02 at 06:37 PM »

I'm using the original Tropico, without any of the add-ons.

Who knows what the heck the "insert disk 0 with data3.cab" problem is caused by?  Why does the game install only the first time, or only sometimes, or sometimes never for different people?  Whether it works or not, you never see the data3.cab file on your CD.  I looked all over the net for information on this, and found similar problems with different games.  Search for "data3.cab" on Google, and you'll see what I'm talking about.  The usual answer to people's complaints is:  "your CD is defective", or "your CD-ROM settings are wrong", to which I see people reply that the problem still remains unfixed.

I've never seen Mucho Macho either, and I have heard that it has two CDs, but in that particular case, my guess would be that Mucho Macho really DOES need a data3.cab.

In the case of the original Tropico, it's clear that the game reallly DOESN'T need a data3.cab; the game plays fine (if you get it to install) without data3.cab, and that's also why you don't see it on the CD.  It's just that, for some reason known only to God (and maybe a few programmers), the original version THINKS it needs data3.cab.

To illustrate that point, try making a copy of the data1.cab or data2.cab file on the CD, paste it to your hard drive, and rename it data3.cab.  When the install asks for data3.cab, point it to the file on your hard drive you just renamed.  You'll notice it doesn't say "invalid file", but proceeds to ask you for a "data4.cab".  Rename the file on your HD to data4.cab, and give the installer that file, and it asks you for a "data5.cab"......and so on, and so on.  The installer will keep incrementing to infinity, because it THINKS it needs additional information, but it really doesn't.  There's a reason why the installer behaves this way, the question is, what is it?

In my case, after pulling my hair out trying to install for four hours, deleting the registry keys somehow tricked the installer into working.  The game is up and running on my machine, with no data3.cab, and works perfectly.

Uninstalling via the Control Panel as Breakaway Mac suggests could probably remove those registry keys the same way, and would be preferrable to editing the registry directly, so if that works, go for it.  It wouldn't surprise me at all that the uninstall on the CD doesn't work, for the simple reason that, Tropico's programmers may want to leave some registry keys behind, to keep track of a person's install history or for security purposes, or whatever.

         
Report to moderator   Logged
Coconut Kid
Tempus Fugit
Deus Ex Machina
********
Offline Offline

Gender: Male
Posts: 7599

ˇay caramba! ~~ ˇparedón!


WWW
« Reply #4 on: 05/15/07 at 08:21 AM »

Bump up to top page since search works only intermittently - it needs to be in view.
Report to moderator   Logged

Pages: [1]   Go Up
  Send this topic  |  Print  
Cafe Tropico  |  Tropico  |  Technical Questions / Troubleshooting (Moderator: CafeDave)  |  Topic: Possible Solution to the data3.cab Problem
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.13 | SMF © 2006-2011, Simple Machines LLC Valid XHTML 1.0! Valid CSS!